aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.7.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-15 14:48:00 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-17 09:56:43 +0000
commit76e5ecbe75c6ef06af7dd662625631399cbbde0f (patch)
tree9b800b80f9758d75eb1d8a91f2ca6de7c1e50fab /meta/recipes-devtools/cmake/cmake-native_3.7.1.bb
parent1c665f441a70cde8450544614d78fbb3bf1664c7 (diff)
downloadopenembedded-core-contrib-76e5ecbe75c6ef06af7dd662625631399cbbde0f.tar.gz
cmake: update to 3.7.1
(From OE-Core rev: 1e15dea62cacdd5c3c1158962a55ca44cfb1726b) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.7.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.7.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.7.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.7.1.bb
new file mode 100644
index 0000000000..7ad4345efe
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.7.1.bb
@@ -0,0 +1,37 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_compile[progress] = "percent"