aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-28 15:34:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:16 +0000
commitf9abf70ef9e55be4bdbf90836a8ba083210f82ad (patch)
treea6d430f0a5e25cba90035f5fffaae24d44b81fe7 /meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
parent1008d711b57d82313e53f767fd6fae93e10418ea (diff)
downloadopenembedded-core-contrib-f9abf70ef9e55be4bdbf90836a8ba083210f82ad.tar.gz
cmake: update to 3.7.0
License is still 3-clause BSD. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.7.0.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.7.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb b/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
new file mode 100644
index 0000000000..7ad4345efe
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
@@ -0,0 +1,37 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_compile[progress] = "percent"