aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-07-27 16:02:57 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-01 11:46:36 +0100
commit3c41b239991baff2bb1facc1e9973c95c9328175 (patch)
tree884b852378cf655034ff551e7de94cecb6a8b9fe /meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
parent2b119c05923e5ecf0338b4ddade07944b13743d1 (diff)
downloadopenembedded-core-contrib-3c41b239991baff2bb1facc1e9973c95c9328175.tar.gz
cmake: upgrade to 3.6.1
3.5.2 -> 3.6.1 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.6.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.6.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
new file mode 100644
index 0000000000..33930fbb9c
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
@@ -0,0 +1,18 @@
+require cmake.inc
+inherit native
+
+# Using cmake's internal libarchive, so some dependencies are needed
+DEPENDS += "bzip2-native zlib-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DBUILD_CursesDialog=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_compile[progress] = "percent"