aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-12-18 17:48:22 +0800
committerRobert Yang <liezhi.yang@windriver.com>2018-12-20 15:01:25 +0800
commit19ac4e33e66353581191e7dfd866f6c0f73eafa6 (patch)
tree6b4e4ada16151a65b3980d1d7bf600febff1ab52 /meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
parent14c291e1fb6324da46885b69fbd7f01b3c6b053e (diff)
downloadopenembedded-core-contrib-rbt/cmake.tar.gz
cmake-native: Set --parallel for configurerbt/cmake
This can save do_configure's time from 330s to 60s on my host. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.12.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.12.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
index 9a1390f96d..3086c82eb6 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
@@ -27,7 +27,9 @@ CMAKE_EXTRACONF = "\
"
do_configure () {
- ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+ ${S}/configure --verbose --prefix=${prefix} \
+ --parallel="${@oe.utils.parallel_make_argument(d, '%d')}" \
+ -- ${CMAKE_EXTRACONF}
}
do_compile() {