summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.12.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-08-30 20:26:04 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-05 17:54:07 +0100
commit439be401cd642937b45796489e8c10aa5238a963 (patch)
tree0d017d4d2855bfb43e2a6fd73eb5c8c2906d24d1 /meta/recipes-devtools/cmake/cmake-native_3.12.1.bb
parent419e63fe1c69eef196f0e7c39ab1fc5b85692bb2 (diff)
downloadopenembedded-core-contrib-439be401cd642937b45796489e8c10aa5238a963.tar.gz
cmake: Update 3.11.4 -> 3.12.1
This updates CMake to the 3.12.1 stable release. All patches were rebase on top of the new source file and all them applied without changes. The number of patches has changed as all them were applied on the Git tree and re-exported, to avoid any fuzzy warnings. License-Update: new contributor added in Copyright.txt Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.12.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.12.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.12.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.12.1.bb
new file mode 100644
index 0000000000..9a1390f96d
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.12.1.bb
@@ -0,0 +1,50 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "file://OEToolchainConfig.cmake \
+ file://environment.d-cmake.sh \
+ file://0001-CMakeDetermineSystem-use-oe-environment-vars-to-load.patch \
+ file://0005-Disable-use-of-ext2fs-ext2_fs.h-by-cmake-s-internal-.patch \
+ "
+
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+
+ # The following codes are here because eSDK needs to provide compatibilty
+ # for SDK. That is, eSDK could also be used like traditional SDK.
+ mkdir -p ${D}${datadir}/cmake
+ install -m 644 ${WORKDIR}/OEToolchainConfig.cmake ${D}${datadir}/cmake/
+ mkdir -p ${D}${base_prefix}/environment-setup.d
+ install -m 644 ${WORKDIR}/environment.d-cmake.sh ${D}${base_prefix}/environment-setup.d/cmake.sh
+}
+
+do_compile[progress] = "percent"
+
+SYSROOT_DIRS_NATIVE += "${datadir}/cmake ${base_prefix}/environment-setup.d"