summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-31 15:49:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-01 23:14:52 +0000
commit15a21998ef8898e11481e77535550fa7ddfd4705 (patch)
tree45e60f0decbba59b8ed7eb9f91474b68dde3d9b2 /meta/recipes-devtools/ccache/ccache_4.1.bb
parent488c554623839d17436333894f9f4b244347de9d (diff)
downloadopenembedded-core-contrib-15a21998ef8898e11481e77535550fa7ddfd4705.tar.gz
ccache: Build fixes for clang and riscv32
Backport patch to improve AVX detection helps build with clang Add proposed patch to fix build with 32bit architectures using 64bit time_t Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.1.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.1.bb b/meta/recipes-devtools/ccache/ccache_4.1.bb
index 5f7d93b485..96254a3875 100644
--- a/meta/recipes-devtools/ccache/ccache_4.1.bb
+++ b/meta/recipes-devtools/ccache/ccache_4.1.bb
@@ -11,7 +11,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=a66c581f855c1c408730fe5d171e3013"
DEPENDS = "zstd"
-SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
+ file://0001-Improve-SIMD-detection-735.patch \
+ file://0002-Always-use-64bit-to-print-time_t.patch \
+ "
SRC_URI[sha256sum] = "cdeefb827b3eef3b42b5454858123881a4a90abbd46cc72cf8c20b3bd039deb7"
UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
@@ -21,4 +24,3 @@ inherit cmake
PATCHTOOL = "patch"
BBCLASSEXTEND = "native"
-