aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-07-28 10:13:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:07 +0100
commitb88b5b7c8d5e60a73b6bd1fa4b3c0b7dc45c9892 (patch)
tree8c60b2cc457b713a81d36e8281ad3a847a1824f6 /meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh
parenta00dcf2a57511fa461e3905d9d1d531872f2d061 (diff)
downloadopenembedded-core-contrib-b88b5b7c8d5e60a73b6bd1fa4b3c0b7dc45c9892.tar.gz
bootchart2: create recipe for bootchart2
This recipe creates packages for the bootchart2 system-wide profiler daemon and related utilities. It fetches the Git revision immediately past the one corresponding to the 0.14.6 release of bootchart2. (0.14.6 had a systemd- related bug that was corrected right after it was tagged.) The recipe contains three packages: * bootchart2 - The daemon itself. * pybootchartgui - Python program to visualize and display the data collected by bootchart2 or compatible daemons such as the original bootchart. * bootchartd-stop-initscript - A SysV init script to stop data collection when booting completes. Depending on how you wish to use bootchart2, you may not end up having all three of those packages installed on your image. There is also a bootchart2-native variant, which is intended solely to provide a native version of the pybootchartgui utility. The non-cross-compiled version of the bootchart2 daemon has not been tested at all, don't use it. The recipe is extensively documented. Read the comments at the beginning of bootchart2_git.bb or else you'll have no idea how to use it. This recipe is based on a recipe from meta-WebOS. The WebOS people had some extra code (including patches against the bootchart2 code) to support the Upstart init system. However, since upstream Poky does not support Upstart, that stuff is being left behind. The WebOS people can write a bbappend to re- add it. Original recipe written by Wonhong Kwon of LG. Upstreamed as part of the solution to [YOCTO #5893]. (From OE-Core rev: d5989b17a210e529c9082d2d3576acc3416586a0) Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh b/meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh
new file mode 100644
index 0000000000..21a78877a2
--- /dev/null
+++ b/meta/recipes-devtools/bootchart2/bootchart2/bootchartd_stop.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: bootchartd_stop
+# Required-Start: $remote_fs $all
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop:
+# Short-Description: Stop bootchartd collection
+# Description: This script accompanies bootchartd from bootchart2.
+# bootchartd should stop detect the end of the boot process
+# automatically if a window manager is launched, but for
+# command-line only operating systems, this script should be
+# used instead.
+### END INIT INFO
+
+/sbin/bootchartd stop
+
+: exit 0