summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-12 17:42:36 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-05-12 17:47:39 +0200
commitef27039138d1fc341fba58474c515dec782d8f8c (patch)
treeaa32431ff84e7edaf74e079eec99a7ca79ac1dfc /meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch
parentc691bc52560e66d7fd08a548789f8e409c1a14d1 (diff)
downloadopenembedded-core-contrib-ef27039138d1fc341fba58474c515dec782d8f8c.tar.gz
binutils: backport gold changes to use mallinfo2 instead of deprecated mallinfojansa/binutils
* mallinfo got deprecacted in glibc-2.33 with: https://sourceware.org/git/?p=glibc.git;a=commit;h=e3960d1c57e57f33e0e846d615788f4ede73b945 https://sourceware.org/git/?p=glibc.git;a=commit;h=30e5069c7d4b51288d3e6f75f53a6ad2f5e71b0f * resolves this warning: oe-core$ grep mallinfo tmp-glibc/work/x86_64-linux/binutils-cross-x86_64/2.36.1-r0/temp/log.do_compile checking whether sbrk is declared... checking for mallinfo... yes ../../gold/main.cc:294:36: warning: ‘mallinfo mallinfo()’ is deprecated [-Wdeprecated-declarations] * after: oe-core$ grep mallinfo tmp-glibc/work/x86_64-linux/binutils-cross-x86_64/2.36.1-r0/temp/log.do_compile checking for struct stat.st_mtim.tv_nsec in sys/stat.h... checking for mallinfo... yes checking whether snprintf is declared... checking for mallinfo2... configure: updating cache ./config.cache the configure output is badly mixed together, but mallinfo2 support was detected OK: oe-core$ grep _mallinfo tmp-glibc/work/x86_64-linux/binutils-cross-x86_64/2.36.1-r0/git/build.x86_64-linux.x86_64-oe-linux/gold/config.log ac_cv_func_mallinfo2=yes ac_cv_func_mallinfo=yes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch')
-rw-r--r--meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch b/meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch
new file mode 100644
index 0000000000..d6e4e25b3d
--- /dev/null
+++ b/meta/recipes-devtools/binutils/binutils/0019-Fix-gold-to-use-mallinfo2-if-available-instead-of-de.patch
@@ -0,0 +1,78 @@
+From 5a47430c1dc7b998b9db3ca9e4c93394c7a9972e Mon Sep 17 00:00:00 2001
+From: Duncan Simpson <dr.duncan.p.simpson@gmail.com>
+Date: Fri, 19 Mar 2021 14:22:08 -0700
+Subject: [PATCH] Fix gold to use mallinfo2 if available instead of deprecated
+ mallinfo.
+
+gold/
+ PR gold/26585
+ * configure.ac: Add check for mallinfo2.
+ * configure: Regenerate.
+ * main.cc (main): Use mallinfo2 if available.
+
+Upstream-Status: Backport [4ee60495054 Fix gold to use mallinfo2 if available instead of deprecated mallinfo.]
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ gold/configure | 2 +-
+ gold/configure.ac | 2 +-
+ gold/main.cc | 9 +++++++--
+ 3 files changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/gold/configure b/gold/configure
+index e264a65ac3c..b9f062b68eb 100755
+--- a/gold/configure
++++ b/gold/configure
+@@ -9967,7 +9967,7 @@ case "$ac_cv_search_dlopen" in
+ esac
+
+
+-for ac_func in mallinfo posix_fallocate fallocate readv sysconf times mkdtemp
++for ac_func in mallinfo mallinfo2 posix_fallocate fallocate readv sysconf times mkdtemp
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_cxx_check_func "$LINENO" "$ac_func" "$as_ac_var"
+diff --git a/gold/configure.ac b/gold/configure.ac
+index eed45664093..1716a779416 100644
+--- a/gold/configure.ac
++++ b/gold/configure.ac
+@@ -636,7 +636,7 @@ case "$ac_cv_search_dlopen" in
+ esac
+ AC_SUBST(DLOPEN_LIBS)
+
+-AC_CHECK_FUNCS(mallinfo posix_fallocate fallocate readv sysconf times mkdtemp)
++AC_CHECK_FUNCS(mallinfo mallinfo2 posix_fallocate fallocate readv sysconf times mkdtemp)
+ AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf, snprintf, vsnprintf, strverscmp, strndup, memmem])
+
+ # Use of ::std::tr1::unordered_map::rehash causes undefined symbols
+diff --git a/gold/main.cc b/gold/main.cc
+index ea77ca3ebbe..89bc40b22af 100644
+--- a/gold/main.cc
++++ b/gold/main.cc
+@@ -25,7 +25,7 @@
+ #include <cstdio>
+ #include <cstring>
+
+-#ifdef HAVE_MALLINFO
++#if defined(HAVE_MALLINFO) || defined(HAVE_MALLINFO2)
+ #include <malloc.h>
+ #endif
+
+@@ -290,11 +290,16 @@ main(int argc, char** argv)
+ elapsed.sys / 1000, (elapsed.sys % 1000) * 1000,
+ elapsed.wall / 1000, (elapsed.wall % 1000) * 1000);
+
+-#ifdef HAVE_MALLINFO
++#if defined(HAVE_MALLINFO2)
++ struct mallinfo m = mallinfo2();
++ fprintf(stderr, _("%s: total space allocated by malloc: %lld bytes\n"),
++ program_name, static_cast<long long>(m.arena));
++#elif defined(HAVE_MALLINFO)
+ struct mallinfo m = mallinfo();
+ fprintf(stderr, _("%s: total space allocated by malloc: %lld bytes\n"),
+ program_name, static_cast<long long>(m.arena));
+ #endif
++
+ File_read::print_stats();
+ Archive::print_stats();
+ Lib_group::print_stats();