aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.16.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-07-03 12:11:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-04 12:27:27 +0100
commitf63a493298de7d0cac36a65dafba5dae06c06a05 (patch)
treeaae22e27c51d22fca134d3861a3d7189ab1ac1f4 /meta/recipes-devtools/automake/automake_1.16.1.bb
parentbff79adccf3b6d7e07abc965af96f9c1d499d309 (diff)
downloadopenembedded-core-contrib-f63a493298de7d0cac36a65dafba5dae06c06a05.tar.gz
automake: 1.15.1 -> 1.16.1
* Refreshed the following patches: - 0001-automake-Add-default-libtool_tag-to-cppasm.patch - automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch - buildtest.patch - new_rt_path_for_test-driver.patch - performance.patch - python-libdir.patch Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.16.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.16.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.16.1.bb b/meta/recipes-devtools/automake/automake_1.16.1.bb
new file mode 100644
index 0000000000..c64ee44d90
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.16.1.bb
@@ -0,0 +1,43 @@
+require automake.inc
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS_class-native = "autoconf-native"
+
+NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
+
+RDEPENDS_${PN} += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-data-dumper \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-thread-queue \
+ perl-module-threads \
+ perl-module-vars "
+
+RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
+RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
+
+SRC_URI += "file://python-libdir.patch \
+ file://buildtest.patch \
+ file://performance.patch \
+ file://new_rt_path_for_test-driver.patch \
+ file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
+ file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
+ "
+
+SRC_URI[md5sum] = "83cc2463a4080efd46a72ba2c9f6b8f5"
+SRC_URI[sha256sum] = "608a97523f97db32f1f5d5615c98ca69326ced2054c9f82e65bade7fc4c9dea8"
+
+PERL = "${USRBINPATH}/perl"
+PERL_class-native = "${USRBINPATH}/env perl"
+PERL_class-nativesdk = "${USRBINPATH}/env perl"
+
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
+
+do_install_append () {
+ install -d ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native nativesdk"