aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.0.9.9.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-05-27 15:58:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-27 17:45:20 +0100
commit7dd4a53a99277b46696dea5558fa321a2267af0a (patch)
treebfeb19ecdc5bb88e73b5550fc85f86564969398d /meta/recipes-devtools/apt/apt_1.0.9.9.bb
parentf58ddacfa153e2bd9fcc79fa1e2c65ae6ef6af02 (diff)
downloadopenembedded-core-contrib-7dd4a53a99277b46696dea5558fa321a2267af0a.tar.gz
apt: upgrade to 1.0.9.9
1. Upgrade to fix the several CVEs: CVE-2014-0488, CVE-2014-0490 2. Remove apt-0.9.9.4-CVE-2014-0478.patch, which was backport. 3. Romve no-ko-translation.patch, apt-1.0.9.9 has ko translation 4. Update use-host.patch no-curl.patch db_linking_hack.patch and noconfigure.patch 5. Not build the test cases since it requires gtest 6. install libapt-private.so.* to libdir, otherwise this file is not installed into sysroot for native, and apt-get will use host's, and lead to fail 7. Revert apt commit[a2a75ff45]"always run 'dpkg --configure -a' at the end of our dpkg callings" for native package, otherwise the postscript for these installed packages will be run, and fail since the rootfs dir is not considered 8. Add lzma dependency by PACKAGECONFIG for target, and add xz dependency for native 9. Support to compile apt-native on centos6 Signed-off-by: Roy Li <rongqing.li@windriver.com> Acked-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.0.9.9.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.0.9.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.0.9.9.bb b/meta/recipes-devtools/apt/apt_1.0.9.9.bb
new file mode 100644
index 0000000000..4c40d0dd49
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.0.9.9.bb
@@ -0,0 +1,22 @@
+DEPENDS = "curl db"
+RDEPENDS_${PN} = "dpkg bash debianutils"
+LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
+require apt.inc
+
+SRC_URI[md5sum] = "e70c6d6227883cfc0dda6bc5db509bca"
+SRC_URI[sha256sum] = "96bebcd7bfee0b2386741a8315182ba39487bdd743ecf5c1fc5b8b889cca2478"
+
+require apt-package.inc
+
+PACKAGECONFIG ??= "lzma"
+PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_install_append() {
+ #Write the correct apt-architecture to apt.conf
+ APT_CONF=${D}/etc/apt/apt.conf
+ echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
+ oe_libinstall -so -C bin libapt-private ${D}${libdir}/
+}