aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.0.10.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-08-05 14:29:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-11 09:04:11 -0700
commit37c8700560b6da569cdf9d7c306a9aa31dcdf06f (patch)
treefc8d85613c2168d51e3ea00f69035677a0c7ebce /meta/recipes-devtools/apt/apt_1.0.10.1.bb
parent82d85bdee7707896cbd432b143eb0ac22c8e3451 (diff)
downloadopenembedded-core-contrib-37c8700560b6da569cdf9d7c306a9aa31dcdf06f.tar.gz
apt: update to 1.0.10.1
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.0.10.1.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.0.10.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.0.10.1.bb b/meta/recipes-devtools/apt/apt_1.0.10.1.bb
new file mode 100644
index 0000000000..bf77e2a301
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.0.10.1.bb
@@ -0,0 +1,18 @@
+DEPENDS = "curl db"
+RDEPENDS_${PN} = "dpkg bash debianutils"
+require apt.inc
+
+require apt-package.inc
+
+PACKAGECONFIG ??= "lzma"
+PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_install_append() {
+ #Write the correct apt-architecture to apt.conf
+ APT_CONF=${D}/etc/apt/apt.conf
+ echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
+ oe_libinstall -so -C bin libapt-private ${D}${libdir}/
+}