aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-05-01 13:00:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-01 23:17:50 +0100
commite6fb2f9afe2ba6b676c46d1eb297ca9cc532d405 (patch)
tree5282f0201ed86aa3aab4273233082b3f8ea7a48b /meta/recipes-core
parentce1f3fd20d81545d6d5dfc68f86f9fddf8ac9bbf (diff)
downloadopenembedded-core-contrib-e6fb2f9afe2ba6b676c46d1eb297ca9cc532d405.tar.gz
Add texinfo.bbclass; recipes that use texinfo utils at build-time inherit it.
The class itself currently does nothing. The idea is to mark all recipes that make use of the texinfo utilities. In the future, this class could be used to suppress the generation/formatting of documentation for performance, explicitly track dependencies on these utilities, and eliminate Yocto's current dependency on the host system's texinfo utilities. Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/coreutils/coreutils_6.9.bb2
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.22.bb2
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc2
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb2
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.3.2.bb2
-rw-r--r--meta/recipes-core/readline/readline.inc2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_6.9.bb b/meta/recipes-core/coreutils/coreutils_6.9.bb
index b9249146a9..debd2a123b 100644
--- a/meta/recipes-core/coreutils/coreutils_6.9.bb
+++ b/meta/recipes-core/coreutils/coreutils_6.9.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
PR = "r5"
DEPENDS_class-native = "gettext-native"
-inherit autotools gettext
+inherit autotools gettext texinfo
SRC_URI_BASE = "${GNU_MIRROR}/coreutils/${BP}.tar.bz2 \
file://gnulib_m4.patch \
diff --git a/meta/recipes-core/coreutils/coreutils_8.22.bb b/meta/recipes-core/coreutils/coreutils_8.22.bb
index 8f378145a9..d5373ae9d6 100644
--- a/meta/recipes-core/coreutils/coreutils_8.22.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.22.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
DEPENDS = "gmp libcap"
DEPENDS_class-native = ""
-inherit autotools gettext
+inherit autotools gettext texinfo
SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
file://remove-usr-local-lib-from-m4.patch \
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 30654f6d88..3a623bb8c7 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -38,7 +38,7 @@ DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial libgcc-initial linux-libc-headers
#RDEPENDS_${PN} += "${@['','libgcc']['nptl' in '${GLIBC_ADDONS}']}"
PROVIDES = "virtual/libc virtual/${TARGET_PREFIX}libc-for-gcc"
PROVIDES += "virtual/libintl virtual/libiconv"
-inherit autotools
+inherit autotools texinfo
require eglibc-options.inc
LEAD_SONAME = "libc.so"
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 5725e7fe07..892194c9ce 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -30,7 +30,7 @@ SRC_URI[sha256sum] = "0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc2
PARALLEL_MAKE = ""
-inherit autotools
+inherit autotools texinfo
EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp --without-emacs"
acpaths = '-I ${S}/autoconf-lib-link/m4/ \
diff --git a/meta/recipes-core/gettext/gettext_0.18.3.2.bb b/meta/recipes-core/gettext/gettext_0.18.3.2.bb
index 553d52223e..65d4103a97 100644
--- a/meta/recipes-core/gettext/gettext_0.18.3.2.bb
+++ b/meta/recipes-core/gettext/gettext_0.18.3.2.bb
@@ -21,7 +21,7 @@ LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread "
SRC_URI[md5sum] = "241aba309d07aa428252c74b40a818ef"
SRC_URI[sha256sum] = "d1a4e452d60eb407ab0305976529a45c18124bd518d976971ac6dc7aa8b4c5d7"
-inherit autotools
+inherit autotools texinfo
EXTRA_OECONF += "--without-lispdir \
--disable-csharp \
diff --git a/meta/recipes-core/readline/readline.inc b/meta/recipes-core/readline/readline.inc
index 6c43e2df11..9d78aa9702 100644
--- a/meta/recipes-core/readline/readline.inc
+++ b/meta/recipes-core/readline/readline.inc
@@ -18,7 +18,7 @@ SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz;name=archive \
S = "${WORKDIR}/${BPN}-${PV}"
-inherit autotools
+inherit autotools texinfo
LEAD_SONAME = "libreadline.so"