aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-02-26 15:49:52 +0200
committerSaul Wold <sgw@linux.intel.com>2014-02-28 11:32:11 +0200
commit8a60d490755c2c3010a87f2616008aee2c9cc966 (patch)
tree1a688225297fd5ed3a30b332228b2b3cb6fadf43 /meta/recipes-core
parent6007b955ce990e493a9dbf225290a9c7e133feee (diff)
downloadopenembedded-core-contrib-8a60d490755c2c3010a87f2616008aee2c9cc966.tar.gz
systemd: sed installed file instead of original
When we change the ROOT_HOME the sed regex does not match if we are running the do_install() a second time, so copy the units files first to a pre_sed, so that the next time, we can copy the the original so that the sed regex is matched correctly in the original [YOCTO #5765] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_208.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_208.bb b/meta/recipes-core/systemd/systemd_208.bb
index 219607f18f..1bcedaa28a 100644
--- a/meta/recipes-core/systemd/systemd_208.bb
+++ b/meta/recipes-core/systemd/systemd_208.bb
@@ -89,6 +89,11 @@ EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
do_configure_prepend() {
export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}"
export KMOD="${base_bindir}/kmod"
+ if [ -d ${S}/units.pre_sed ] ; then
+ cp -r ${S}/units.pre_sed ${S}/units
+ else
+ cp -r ${S}/units ${S}/units.pre_sed
+ fi
sed -i -e 's:=/root:=${ROOT_HOME}:g' ${S}/units/*.service*
}