summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-05-23 07:58:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-27 17:06:27 +0100
commit71c6930e304f8918e4bd571237ff41e7e9e9b9a3 (patch)
treeab3d6a971e6758b308a3d3c2f78748c2157b10b8 /meta/recipes-core
parenta9bf875af4a5133e4f0e3039a76b1dfc6d5d1f63 (diff)
downloadopenembedded-core-contrib-71c6930e304f8918e4bd571237ff41e7e9e9b9a3.tar.gz
Revert "musl: Add TEMP_FAILURE_RETRY from glibc"
This reverts commit 0c68c621d3b8690e3a346170006f75b032511a8a. It should be upstreamed first Secondly, musl and glibc are under different licenses and importing code from one to other could taint it. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/musl/musl/0001-unistd.h-Add-TEMP_FAILURE_RETRY.patch36
-rw-r--r--meta/recipes-core/musl/musl_git.bb1
2 files changed, 0 insertions, 37 deletions
diff --git a/meta/recipes-core/musl/musl/0001-unistd.h-Add-TEMP_FAILURE_RETRY.patch b/meta/recipes-core/musl/musl/0001-unistd.h-Add-TEMP_FAILURE_RETRY.patch
deleted file mode 100644
index 4d48d61651..0000000000
--- a/meta/recipes-core/musl/musl/0001-unistd.h-Add-TEMP_FAILURE_RETRY.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 19cbebc3fa33c6a1a71a6036da4d67c98f859f06 Mon Sep 17 00:00:00 2001
-From: Adrian Bunk <bunk@stusta.de>
-Date: Wed, 15 May 2019 16:08:33 +0300
-Subject: unistd.h: Add TEMP_FAILURE_RETRY
-
-Signed-off-by: Adrian Bunk <bunk@stusta.de>
-Upstream-Status: Inappropriate [oe-specific]
----
- include/unistd.h | 11 +++++++++++
- 1 file changed, 11 insertions(+)
-
-diff --git a/include/unistd.h b/include/unistd.h
-index 9485da7a..8a75af57 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -460,6 +460,17 @@ int eaccess(const char *, int);
- #define _CS_V6_ENV 1148
- #define _CS_V7_ENV 1149
-
-+#ifdef _GNU_SOURCE
-+#ifndef TEMP_FAILURE_RETRY
-+# define TEMP_FAILURE_RETRY(expression) \
-+ (__extension__ \
-+ ({ long int __result; \
-+ do __result = (long int) (expression); \
-+ while (__result == -1L && errno == EINTR); \
-+ __result; }))
-+#endif
-+#endif
-+
- #ifdef __cplusplus
- }
- #endif
---
-2.20.1
-
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 2b433aed8c..1e324804e1 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -15,7 +15,6 @@ PV = "${BASEVER}+git${SRCPV}"
SRC_URI = "git://git.musl-libc.org/musl \
file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
- file://0001-unistd.h-Add-TEMP_FAILURE_RETRY.patch \
"
S = "${WORKDIR}/git"