summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMingde (Matthew) Zeng <matthew.zeng@windriver.com>2020-02-18 14:46:49 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-19 11:23:33 +0000
commitb649cf5c09a45df2df9a8f8f0920c6dfb07b8d76 (patch)
tree1af251539450b77926ccab9294b4d939f162f2dd /meta/recipes-core
parenta40a93e81766513cf710e713093ab74c6ec936c3 (diff)
downloadopenembedded-core-contrib-b649cf5c09a45df2df9a8f8f0920c6dfb07b8d76.tar.gz
glib-2.0: add dependencies to fix ptest failures
There are a number of ptest failures due to executables not found in the image. Since these executables are in FILES_${PN}-dev, depending all of -dev which is an overkill. We take them out of -dev and put in -utils, then depend on the latter instead. When starting a glib ptest but decided to Ctrl-c interrupt midway, ./run-ptest cannot be restarted unless running `userdel glib2-test` manually. Therefore adding a check prior to ptest will ensure the ptest can be restarted. Signed-off-by: Matthew Zeng <matthew.zeng@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/run-ptest3
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc12
2 files changed, 11 insertions, 4 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/run-ptest b/meta/recipes-core/glib-2.0/glib-2.0/run-ptest
index fc50082c8e..7a231b514b 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0/run-ptest
+++ b/meta/recipes-core/glib-2.0/glib-2.0/run-ptest
@@ -1,6 +1,9 @@
#! /bin/sh
set -eux
+if id -u glib2-test; then
+ userdel glib2-test
+fi
useradd glib2-test
su glib2-test -c 'gnome-desktop-testing-runner glib'
userdel glib2-test
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index f4aff297e5..23c347dbf7 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -58,13 +58,15 @@ FILES_${PN} = "${libdir}/lib*${SOLIBS} \
${libdir}/gio \
${libexecdir}/*gio-querymodules \
${datadir}/glib-2.0/schemas"
+
+FILES_${PN}-utils += "${bindir}/glib-genmarshal \
+ ${bindir}/glib-gettextize \
+ ${bindir}/glib-mkenums \
+ ${bindir}/glib-compile-resources"
+
FILES_${PN}-dev += "${libdir}/glib-2.0/include \
${libdir}/gio/modules/lib*${SOLIBSDEV} \
${libdir}/gio/modules/*.la \
- ${bindir}/glib-genmarshal \
- ${bindir}/glib-gettextize \
- ${bindir}/glib-mkenums \
- ${bindir}/glib-compile-resources \
${datadir}/glib-2.0/gettext/po/Makefile.in.in \
${datadir}/glib-2.0/schemas/gschema.dtd \
${datadir}/glib-2.0/valgrind/glib.supp \
@@ -138,6 +140,8 @@ CODEGEN_PYTHON_RDEPENDS_mingw32 = ""
RDEPENDS_${PN}-codegen += "${CODEGEN_PYTHON_RDEPENDS}"
+RDEPENDS_${PN}-ptest += "${PN}-utils"
+
RDEPENDS_${PN}-ptest += "\
coreutils \
libgcc \