summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>2020-01-20 09:23:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-04 15:56:24 +0000
commit4535469d5953b94c9dcad5515be9b807ea7ba621 (patch)
treebd3603f7b08fb3b771ae81e1f5d2893f2410b1bb /meta/recipes-core
parent6217c3a7201b34888aa2fbae8b6e490bea545574 (diff)
downloadopenembedded-core-contrib-4535469d5953b94c9dcad5515be9b807ea7ba621.tar.gz
glibc: don't ignore global LDFLAGS settings
Two things: The -Wl,-rpath-link comment is stale (due to per-recipe staging), so we no longer need to set our own LDFLAGS to avoid -Wl,-rpath-link being in there. Second, overriding LDFLAGS should be done at the recipe level so "bitbake -e" can show what is going on. Otherwise debugging why one's global LDFLAGS tweaks are being ignored is needlessly painful. So pull out the LDFLAGS setting from do_compile, and change it to an append instead of assignment. For the benefit of future git blame: the -fuse-ld=bfd setting was added by ac64c3b96b (glibc: always use bfd linker). Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glibc/glibc_2.31.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.31.bb b/meta/recipes-core/glibc/glibc_2.31.bb
index 9f299a7bc3..2032311b27 100644
--- a/meta/recipes-core/glibc/glibc_2.31.bb
+++ b/meta/recipes-core/glibc/glibc_2.31.bb
@@ -91,9 +91,8 @@ do_configure () {
CPPFLAGS="" oe_runconf
}
+LDFLAGS += "-fuse-ld=bfd"
do_compile () {
- # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
- LDFLAGS="-fuse-ld=bfd"
base_do_compile
echo "Adjust ldd script"
if [ -n "${RTLDLIST}" ]