summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2019-09-20 09:25:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-27 13:01:17 +0100
commit9f9706d39713f967e10e3a41313ddacb03b0ca94 (patch)
tree5835cf0235647e43fca849761d086fb1501e7c31 /meta/recipes-core
parentca07f88c21094a04f6af1f87bc7d9afa477e30f1 (diff)
downloadopenembedded-core-contrib-9f9706d39713f967e10e3a41313ddacb03b0ca94.tar.gz
systemd: Make it build with hwdb disabled
If hwdb is disabled, then systemd-hwdb-update.service does not exists. Do not try to modify it in this case. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_243.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd_243.bb b/meta/recipes-core/systemd/systemd_243.bb
index f0e8c569b8..d0f9d17dba 100644
--- a/meta/recipes-core/systemd/systemd_243.bb
+++ b/meta/recipes-core/systemd/systemd_243.bb
@@ -299,9 +299,10 @@ do_install() {
}
do_install_append () {
- # Mips qemu is extremely slow, allow more time for the hwdb update
- # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
- sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
+ # Mips qemu is extremely slow, allow more time for the hwdb update
+ # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
+ [ ! -e ${D}${systemd_unitdir}/system/systemd-hwdb-update.service ] ||
+ sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
}
python populate_packages_prepend (){