aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-11-14 11:39:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-29 23:41:34 +0000
commit8fb362d90628d0dbc9a5073a0d75296eab569d44 (patch)
tree83353dc8a511f7389c9f1e03da11f80c4d76dff7 /meta/recipes-core
parent84c841c5b4d3ae753c377f5bdbda19281c771f60 (diff)
downloadopenembedded-core-contrib-8fb362d90628d0dbc9a5073a0d75296eab569d44.tar.gz
systemd: use consistent approach for musl PACKAGECONFIG options
Consistently use PACKAGECONFIG_remove_libc-musl to disable options which are not compatible with musl. Also sort the default PACKAGECONFIG list. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb67
1 files changed, 38 insertions, 29 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 69465388b2..b7968b15aa 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -50,36 +50,45 @@ PAM_PLUGINS = " \
pam-plugin-keyinit \
"
-PACKAGECONFIG ??= "xz \
- ${@bb.utils.filter('DISTRO_FEATURES', 'efi pam selinux ldconfig usrmerge', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'rfkill', '', d)} \
- binfmt \
- randomseed \
- machined \
- backlight \
- vconsole \
- quotacheck \
- hostnamed \
- ${@bb.utils.contains('TCLIBC', 'glibc', 'myhostname sysusers utmp', '', d)} \
- nss \
- hibernate \
- timedated \
- timesyncd \
- localed \
- ima \
- smack \
- logind \
- firstboot \
- polkit \
- resolved \
- networkd \
+PACKAGECONFIG ??= " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'efi ldconfig pam selinux usrmerge', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'rfkill', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)} \
+ backlight \
+ binfmt \
+ firstboot \
+ hibernate \
+ hostnamed \
+ ima \
+ localed \
+ logind \
+ machined \
+ myhostname \
+ networkd \
+ nss \
+ polkit \
+ quotacheck \
+ randomseed \
+ resolved \
+ smack \
+ sysusers \
+ timedated \
+ timesyncd \
+ utmp \
+ vconsole \
+ xz \
+"
+
+PACKAGECONFIG_remove_libc-musl = " \
+ localed \
+ myhostname \
+ nss \
+ resolved \
+ selinux \
+ smack \
+ sysusers \
+ utmp \
"
-PACKAGECONFIG_remove_libc-musl = "selinux"
-PACKAGECONFIG_remove_libc-musl = "smack"
-PACKAGECONFIG_remove_libc-musl = "resolved"
-PACKAGECONFIG_remove_libc-musl = "nss"
-PACKAGECONFIG_remove_libc-musl = "localed"
# Use the upstream systemd serial-getty@.service and rely on
# systemd-getty-generator instead of using the OE-core specific