summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-02-03 19:08:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-05 08:16:28 +0000
commitafc9ba7d546f3f2e60fb6f46f740dc925542df16 (patch)
treeea42986e732be9531fcea569d536eb3535be5659 /meta/recipes-core
parent8d05c277c5350c4d968eb488788eac7978968ef7 (diff)
downloadopenembedded-core-contrib-afc9ba7d546f3f2e60fb6f46f740dc925542df16.tar.gz
glib-2.0: add workaround to fix codegen.py.test failing
Adding a patch to remove an unecessary print statement in test-codegen.py that cause the ptest-runner to fail. Root cause is suspected to be in ptest-runner. [YOCTO #14170] Uptream-Status: Inappropriate [other] this is a workaround. Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/0001-tests-codegen.py-removing-unecessary-print-statement.patch38
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.66.4.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/0001-tests-codegen.py-removing-unecessary-print-statement.patch b/meta/recipes-core/glib-2.0/glib-2.0/0001-tests-codegen.py-removing-unecessary-print-statement.patch
new file mode 100644
index 0000000000..40427e0e67
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/0001-tests-codegen.py-removing-unecessary-print-statement.patch
@@ -0,0 +1,38 @@
+From 6178df5658045a6253ef806e018fe80d99a8f5fb Mon Sep 17 00:00:00 2001
+From: Yi Fan Yu <yifan.yu@windriver.com>
+Date: Mon, 1 Feb 2021 16:10:28 -0500
+Subject: [PATCH] tests/codegen.py: removing unecessary print statement
+
+A huge amount of output(boiler-plate code) is
+printed to the console screen.
+This is not critical to the test results.
+
+This causes intermittent test failure when another process
+has to parse its output.
+
+Root cause is in ptest-runner, This is a workaround
+
+Uptream-Status: Inappropriate [other]
+
+
+
+Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
+---
+ gio/tests/codegen.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gio/tests/codegen.py b/gio/tests/codegen.py
+index 51de0ede4..cfa4db42e 100644
+--- a/gio/tests/codegen.py
++++ b/gio/tests/codegen.py
+@@ -250,7 +250,6 @@ class TestCodegen(unittest.TestCase):
+
+ result = Result(info, out, err, subs)
+
+- print('Output:', result.out)
+ return result
+
+ def runCodegenWithInterface(self, interface_contents, *args):
+--
+2.29.2
+
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.66.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.66.4.bb
index 70e8aa8785..5e1c0f2d33 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.66.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.66.4.bb
@@ -17,6 +17,7 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
file://0001-gio-tests-codegen.py-bump-timeout-to-100-seconds.patch \
+ file://0001-tests-codegen.py-removing-unecessary-print-statement.patch \
"
SRC_URI_append_class-native = " file://relocate-modules.patch"