summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-08-29 13:09:41 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-01 22:33:08 +0100
commitc4f07b04f69620c33b4c5e8903b408381bc5d0f3 (patch)
treeeaa7ecb186ade1d86347e1f9cc3e03598d545fbd /meta/recipes-core
parent0458fa6b831b4d656f31dc6f4c7221e7f87ebc4a (diff)
downloadopenembedded-core-contrib-c4f07b04f69620c33b4c5e8903b408381bc5d0f3.tar.gz
libxcrypt: Fix the build with -Os
| In file included from ../git/lib/alg-des.c:66: | ../git/lib/alg-des.c: In function '_crypt_des_set_key': | ../git/lib/byteorder.h:24:1: error: inlining failed in call to 'be32_to_cpu': call is unlikely and code size would grow [-Werror=inline] | be32_to_cpu (const unsigned char *buf) | ^~~~~~~~~~~ | ../git/lib/alg-des.c:81:13: note: called from here | rawkey1 = be32_to_cpu (&key[4]); | ^~~~~~~~~~~~~~~~~~~~~ (From OE-Core rev: 5d4720dfc8ec29ff3f487f84c5c874678ba20851) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
index 893f5e7379..5270e58c2b 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
@@ -26,8 +26,8 @@ FILES_${PN} = "${libdir}/libcrypt*.so.* \
S = "${WORKDIR}/git"
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
-TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
-CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error"
+CPPFLAGS_append_class-nativesdk = " -Wno-error"
API = "--disable-obsolete-api"
EXTRA_OECONF += "${API}"