aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-02-09 18:13:50 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-12 00:31:43 +0000
commit92a9d59fccdfb6587fbd12f686899a8ace5e1d2f (patch)
treeee21a7f2eff64edb141297e75cfda174b8e45bf9 /meta/recipes-core
parent6f6bffe5df1edf10056f42d2c95ae68b6bb918f9 (diff)
downloadopenembedded-core-contrib-92a9d59fccdfb6587fbd12f686899a8ace5e1d2f.tar.gz
recipes: pre/post actions
A number of the recipes did not properly label their pre and post actions, causing the actions to occur in all split packages. This was corrected by defaulting to _${PN} in most cases. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb2
-rw-r--r--meta/recipes-core/dropbear/dropbear.inc4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
index b8263671de..aed84914bf 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -40,7 +40,7 @@ do_install_append_openmn() {
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
set -e
if [ ! -e $D${sysconfdir}/passwd ] ; then
diff --git a/meta/recipes-core/dropbear/dropbear.inc b/meta/recipes-core/dropbear/dropbear.inc
index dd2f0c5b53..ab7719c469 100644
--- a/meta/recipes-core/dropbear/dropbear.inc
+++ b/meta/recipes-core/dropbear/dropbear.inc
@@ -63,12 +63,12 @@ do_install() {
chmod 755 ${D}${sysconfdir}/init.d/dropbear
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/scp scp ${sbindir}/dropbearmulti 20
update-alternatives --install ${bindir}/ssh ssh ${sbindir}/dropbearmulti 20
}
-pkg_postrm_append () {
+pkg_postrm_append_${PN} () {
if [ -f "${sysconfdir}/dropbear/dropbear_rsa_host_key" ]; then
rm ${sysconfdir}/dropbear/dropbear_rsa_host_key
fi