aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-18 00:03:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-31 12:56:38 +0100
commit26e5e5feb695864b11e47e24017e254c28f14494 (patch)
tree754537dc0577fdcb6cf753bfbd926aeb74183789 /meta/recipes-core
parent5c3f39c56d1a7402c1f1f3b6db1f2764fcc8f190 (diff)
downloadopenembedded-core-contrib-26e5e5feb695864b11e47e24017e254c28f14494.tar.gz
Improve handling of 'all' architecture recipes and their interaction with sstate
The existing PACKAGE_ARCH = "all" mechanism of sharing packages is problematic with sstate since there are a variety of variables which have target specific values and the sstate package therefore correctly changes signature depending on the MACHINE setting. This patch creates a new "allarch" class which sets: PACKAGE_ARCH = "all" (as per the existing convention) INHIBIT_DEFAULT_DEPS = "1" (since its not target specific and therefore can't depend on the cross compiler or target libc) TARGET_ARCH = "all" TARGET_OS = "linux" TARGET_CC_ARCH = "none" (since these variables shouldn't change between the different packages and target compiler flags shouldn't be getting used) PACKAGE_EXTRA_ARCHS = "" (since we shouldn't be depending on any architecture specific package architectures) Not all PACKAGE_ARCH = "all" recipes can use this class since some run configure checks on the compiler. This means they have target specific components and therefore the "all" classification is incorrect. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb5
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb5
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb5
-rw-r--r--meta/recipes-core/update-rc.d/update-rc.d_0.7.bb4
4 files changed, 11 insertions, 8 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
index b372fddbba..704c2718a0 100644
--- a/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
@@ -3,11 +3,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "file://init-boot.sh"
-PR = "r0"
+PR = "r1"
do_install() {
install -m 0755 ${WORKDIR}/init-boot.sh ${D}/init
}
-PACKAGE_ARCH = "all"
+inherit allarch
+
FILES_${PN} += " /init "
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
index f6a6a8a4cb..7051cbd32a 100644
--- a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
@@ -3,11 +3,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "file://init-live.sh"
-PR = "r2"
+PR = "r3"
do_install() {
install -m 0755 ${WORKDIR}/init-live.sh ${D}/init
}
-PACKAGE_ARCH = "all"
+inherit allarch
+
FILES_${PN} += " /init "
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
index c599be5c58..fdda71819f 100644
--- a/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "file://init-install.sh"
-PR = "r3"
+PR = "r4"
RDEPENDS="grub parted e2fsprogs-mke2fs"
@@ -11,7 +11,8 @@ do_install() {
install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
}
-PACKAGE_ARCH = "all"
+inherit allarch
+
FILES_${PN} = " /install.sh "
# Alternatives to grub need adding for other arch support
diff --git a/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb b/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
index 6a43d809ed..38da4233ea 100644
--- a/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
+++ b/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
@@ -2,18 +2,18 @@ SUMMARY = "manage symlinks in /etc/rcN.d."
DESCRIPTION = "update-rc.d is a utilities that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
SECTION = "base"
PRIORITY = "standard"
-PACKAGE_ARCH = "all"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://github.com/philb/update-rc.d.git;tag=update-rc.d_${PV};protocol=git \
file://add-verbose.patch;striplevel=1"
S = "${WORKDIR}/git"
+inherit allarch
do_compile() {
}