summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-19 11:20:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-20 00:03:01 +0000
commit77a6ac0ac266d71e4fe67fd332662081f30cd7bf (patch)
tree965070e00182b2fcf0d888230c99b93d9afc288d /meta/recipes-core
parentacf78fd3d03e4fe07ee4ad677f178d17dc10ac7b (diff)
downloadopenembedded-core-contrib-77a6ac0ac266d71e4fe67fd332662081f30cd7bf.tar.gz
systemd: Ensure uid/gid ranges are set deterministically
meson.build will fall back to greping /etc/login.defs for values of these if they're not set. Different distros set them (Centos 7/8 does, Ubuntu does not) so output was not deterministic. Avoid this by setting to the default values. We now match the vaules from login.defs from shadow. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_247.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_247.2.bb b/meta/recipes-core/systemd/systemd_247.2.bb
index 15f8cb3d71..5eea78eff3 100644
--- a/meta/recipes-core/systemd/systemd_247.2.bb
+++ b/meta/recipes-core/systemd/systemd_247.2.bb
@@ -213,6 +213,10 @@ EXTRA_OEMESON += "-Dnobody-user=nobody \
-Drootprefix=${rootprefix} \
-Ddefault-locale=C \
-Dmode=release \
+ -Dsystem-alloc-uid-min=101 \
+ -Dsystem-uid-max=999 \
+ -Dsystem-alloc-gid-min=101 \
+ -Dsystem-gid-max=999 \
"
# Hardcode target binary paths to avoid using paths from sysroot