summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-12-14 18:31:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-18 22:52:13 +0000
commit00191504bd9321334a5c01b95179ed15b063f1b6 (patch)
tree9aa82e38b901ef4071a72f718539952d2e3432a9 /meta/recipes-core
parentd3bf2d0fbd50309d7cf8f066c258ba1ebdb05f47 (diff)
downloadopenembedded-core-contrib-00191504bd9321334a5c01b95179ed15b063f1b6.tar.gz
systemd-boot: build the EFI stub
Also build and deploy the EFI stub. SYSTEMD_BOOT_EFI_ARCH can be dropped as image-uefi.conf now sets EFI_ARCH. Changes originally taken from meta-intel. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_246.6.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_246.6.bb b/meta/recipes-core/systemd/systemd-boot_246.6.bb
index f92c639810..97093e4bb2 100644
--- a/meta/recipes-core/systemd/systemd-boot_246.6.bb
+++ b/meta/recipes-core/systemd/systemd-boot_246.6.bb
@@ -47,16 +47,14 @@ RDEPENDS_${PN} += "virtual/systemd-bootconf"
# Imported from the old gummiboot recipe
TUNE_CCARGS_remove = "-mfpmath=sse"
+
COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
COMPATIBLE_HOST_x86-x32 = "null"
do_compile() {
- SYSTEMD_BOOT_EFI_ARCH="ia32"
- if [ "${TARGET_ARCH}" = "x86_64" ]; then
- SYSTEMD_BOOT_EFI_ARCH="x64"
- fi
-
- ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
+ ninja \
+ src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE} \
+ src/boot/efi/linux${EFI_ARCH}.efi.stub
}
do_install() {
@@ -66,5 +64,7 @@ do_install() {
do_deploy () {
install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
+ install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
}
+
addtask deploy before do_build after do_compile