summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-24 16:52:21 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:43:43 +0100
commit0d29dc5b5f7742df60fdba90835ef77425963bde (patch)
treef9e1ac660705f7e1585140635cf48245fdf09be4 /meta/recipes-core
parent778cd8d2110ef2db5ff4ae4f0b55c52a8f1ea334 (diff)
downloadopenembedded-core-contrib-0d29dc5b5f7742df60fdba90835ef77425963bde.tar.gz
busybox: Add ptest
Install busybox test suite and run it as ptest. Signed-off-by: Anders Roxell <anders.roxell@enea.com> Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/busybox/busybox.inc2
-rw-r--r--meta/recipes-core/busybox/busybox_1.20.2.bb7
-rw-r--r--meta/recipes-core/busybox/files/run-ptest7
3 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index 65e16424cc..8567d6471f 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -44,7 +44,7 @@ CONFFILES_${PN}-mdev = "${sysconfdir}/mdev.conf"
RRECOMMENDS_${PN} = "${PN}-syslog ${PN}-udhcpc"
-inherit cml1 systemd update-rc.d
+inherit cml1 systemd update-rc.d ptest
# internal helper
def busybox_cfg(feature, features, tokens, cnf, rem):
diff --git a/meta/recipes-core/busybox/busybox_1.20.2.bb b/meta/recipes-core/busybox/busybox_1.20.2.bb
index a2e762d451..c854f0b2bd 100644
--- a/meta/recipes-core/busybox/busybox_1.20.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.20.2.bb
@@ -34,6 +34,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://strict-atime.patch \
file://fail_on_no_media.patch \
file://busybox-sulogin-empty-root-password.patch \
+ file://run-ptest \
file://inetd.conf \
file://inetd \
file://login-utilities.cfg \
@@ -43,3 +44,9 @@ SRC_URI[tarball.md5sum] = "e025414bc6cd79579cc7a32a45d3ae1c"
SRC_URI[tarball.sha256sum] = "eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882"
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
+
+do_install_ptest () {
+ cp -r ${B}/testsuite ${D}${PTEST_PATH}/
+ cp ${B}/.config ${D}${PTEST_PATH}/
+ ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
+}
diff --git a/meta/recipes-core/busybox/files/run-ptest b/meta/recipes-core/busybox/files/run-ptest
new file mode 100644
index 0000000000..3608a8eb65
--- /dev/null
+++ b/meta/recipes-core/busybox/files/run-ptest
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+current_dir=$(readlink -f $0)
+export bindir=$(dirname $current_dir)
+
+cd testsuite || exit 1
+./runtest -v | sed -r 's/^(SKIPPED|UNTESTED):/SKIP:/'