aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2014-01-10 08:15:03 +0100
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:20 +0100
commitf177f5cd6bc68e81b0b49393916aa87a36fc09b8 (patch)
treea33c3d33ce2ec1d44a9469901311ff8ba37aaf65 /meta/recipes-core
parent6c40c26d3a6fbeb9fd724c50d918cf293d64a67d (diff)
downloadopenembedded-core-contrib-f177f5cd6bc68e81b0b49393916aa87a36fc09b8.tar.gz
systemd-compat-units: do not mask available services
Do also check systemd_unitdir/system/ for available unit files. This was hiding dnsmasq.service for us, as /etc/systemd/system has priority over systemd_unitdir/system... Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Saul Wold <sgw@linux.intel.com> (cherry picked from commit 5aea3d375b717d96f8f916f2f830e8f8649a4991) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index e4d93d2c88..ffdc55bf02 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -42,7 +42,7 @@ pkg_postinst_${PN} () {
fi
for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
- if [ \( -e $i -o $i.sh \) -a ! -e $D${sysconfdir}/systemd/system/$i.service ] ; then
+ if [ \( -e $i -o $i.sh \) -a ! \( -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service \) ] ; then
echo -n "$i: " ; systemctl ${OPTS} mask $i.service
fi
done ; echo