aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-27 12:54:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-29 19:33:25 +0100
commit87606439e7eadcdcbea510b3facf8754ed7d0220 (patch)
tree4d264b636d81674836264908c03c44adf4cfd85c /meta/recipes-core
parent66ee51986db68e1bcd7d8e2b5e91dcdbcb0e6d84 (diff)
downloadopenembedded-core-contrib-87606439e7eadcdcbea510b3facf8754ed7d0220.tar.gz
eudev: add PACKAGECONFIG for hwdb
Some users may not want the hwdb at all, so add a PACKAGECONFIG option to disable building it entirely. (From OE-Core rev: 7006d3084bd4d6aab2ca64d052df3a014abaf813) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/udev/eudev_3.1.5.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/udev/eudev_3.1.5.bb b/meta/recipes-core/udev/eudev_3.1.5.bb
index ea19ec4138..e42630f5cf 100644
--- a/meta/recipes-core/udev/eudev_3.1.5.bb
+++ b/meta/recipes-core/udev/eudev_3.1.5.bb
@@ -32,6 +32,9 @@ EXTRA_OECONF = " \
--with-rootprefix= \
"
+PACKAGECONFIG ??= "hwdb"
+PACKAGECONFIG[hwdb] = "--enable-hwdb,--disable-hwdb"
+
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
@@ -104,4 +107,3 @@ pkg_postinst_eudev-hwdb () {
pkg_prerm_eudev-hwdb () {
rm -f $D${sysconfdir}/udev/hwdb.bin
}
-