aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-09 17:11:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 09:29:41 -0800
commit8de0c5d3bd01919e2bf0394f9c485936d6098cec (patch)
treeb0c04737cc79f4f0da8d93082ed5a016726dfa86 /meta/recipes-core
parentd1109378d730c5cf50240c4d1a468e3aef5208ea (diff)
downloadopenembedded-core-contrib-8de0c5d3bd01919e2bf0394f9c485936d6098cec.tar.gz
classes: Drop now unneeded update_data calls
Now that the datastore works dynamically we don't need the update_data calls so we can just remove them. They're not actually done anything at all for a while. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glibc/glibc-ld.inc1
-rw-r--r--meta/recipes-core/meta/meta-environment.bb1
2 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-core/glibc/glibc-ld.inc b/meta/recipes-core/glibc/glibc-ld.inc
index c26643707d..b89b70a293 100644
--- a/meta/recipes-core/glibc/glibc-ld.inc
+++ b/meta/recipes-core/glibc/glibc-ld.inc
@@ -37,7 +37,6 @@ def glibc_dl_info(d):
localdata = bb.data.createCopy(d)
overrides = localdata.getVar("OVERRIDES", False) + ":virtclass-multilib-" + item
localdata.setVar("OVERRIDES", overrides)
- bb.data.update_data(localdata)
ld_append_if_tune_exists(localdata, infos, ld_info_all)
infos['ldconfig'] = ','.join(infos['ldconfig'])
infos['lddrewrite'] = ' '.join(infos['lddrewrite'])
diff --git a/meta/recipes-core/meta/meta-environment.bb b/meta/recipes-core/meta/meta-environment.bb
index c7ac05d62a..29da121a3a 100644
--- a/meta/recipes-core/meta/meta-environment.bb
+++ b/meta/recipes-core/meta/meta-environment.bb
@@ -43,7 +43,6 @@ python do_generate_content() {
overrides = d.getVar("OVERRIDES", False) + ":virtclass-multilib-" + item
localdata.setVar("OVERRIDES", overrides)
localdata.setVar("MLPREFIX", item + "-")
- bb.data.update_data(localdata)
bb.build.exec_func("create_sdk_files", localdata)
}
addtask generate_content before do_install after do_compile