aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2016-07-12 16:50:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-31 14:43:02 +0000
commit5d847e64247bc856b9369cccd2775320135eb7b6 (patch)
tree674a83a2b8d23e27f405881c811c790785f02333 /meta/recipes-core
parentd053ce30718ab17e6eef843f7acef249f4f0f6a5 (diff)
downloadopenembedded-core-contrib-5d847e64247bc856b9369cccd2775320135eb7b6.tar.gz
core-image-tiny-initramfs: Add and image creating image artifacts only
Add an image that simply creates image artifacts using image-live-artifacts support instead of creating an actual image. The image artifacts can then be subsequently assembled by an external tool such as wic to create an actual image. This eliminates redundant image creation when using such tools. (From OE-Core rev: 97237259a9acb9a1511823914dea52b9719fbafd) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/core-image-tiny-initramfs.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/images/core-image-tiny-initramfs.bb b/meta/recipes-core/images/core-image-tiny-initramfs.bb
new file mode 100644
index 0000000000..846d58930e
--- /dev/null
+++ b/meta/recipes-core/images/core-image-tiny-initramfs.bb
@@ -0,0 +1,30 @@
+# Simple initramfs image artifact generation for tiny images.
+DESCRIPTION = "Tiny image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first 'init' program more efficiently. core-image-tiny-initramfs doesn't \
+actually generate an image but rather generates boot and rootfs artifacts \
+into a common location that can subsequently be picked up by external image \
+generation tools such as wic."
+
+PACKAGE_INSTALL = "initramfs-live-boot packagegroup-core-boot dropbear ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "core-image-tiny-initramfs"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+# don't actually generate an image, just the artifacts needed for one
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES} wic"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+# Use the same restriction as initramfs-live-install
+COMPATIBLE_HOST = "(i.86|x86_64).*-linux"