aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKristian Amlie <kristian.amlie@mender.io>2017-01-30 16:43:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-02 17:37:43 +0000
commit47be19240f90297516156741d6e5f5ddfe0b9da5 (patch)
tree1c6f27bcf402fea711a14974b2c113e952bc70dc /meta/recipes-core
parent6b149b6dbd6a3d709335317685644d55617225f4 (diff)
downloadopenembedded-core-contrib-47be19240f90297516156741d6e5f5ddfe0b9da5.tar.gz
wic-tools: Do not remove sysroot with rm_work, because wic needs it.
The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will be removed before wic has a chance to use it, hence this fix. (From OE-Core rev: fc59d35a8ceae6302e0a161bab04829fdfd157cd) Signed-off-by: Kristian Amlie <kristian.amlie@mender.io> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/wic-tools.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index 1d9ea9c0e9..bd4319a803 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -9,6 +9,10 @@ DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
INHIBIT_DEFAULT_DEPS = "1"
inherit nopackages
+# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
+# be removed before wic has a chance to use it, hence the exclusion below.
+RM_WORK_EXCLUDE += "${PN}"
+
python do_build_sysroot () {
bb.build.exec_func("extend_recipe_sysroot", d)