aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-10-14 21:38:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-15 10:01:44 +0100
commitbe587dbc7043f154263b2099c5eaaad16e63739e (patch)
treeb0608c8b7475ae779aed49df3a9d0aff77978678 /meta/recipes-core
parent2a2592e0fdb30ce02157e60019a89220f31a0bae (diff)
downloadopenembedded-core-contrib-be587dbc7043f154263b2099c5eaaad16e63739e.tar.gz
libxml2: Make tests non-executable
The XML W3C conformance test suite contains thousands of xml files all marked executable. We dutifully try to strip all these files of debug info in do_package. "chmod -x" improves build time by ~40 seconds. (From OE-Core rev: eb9cdf6b9277d23d1696233fccc4689e6030644c) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.4.bb b/meta/recipes-core/libxml/libxml2_2.9.4.bb
index 265d2b73a9..59874bec2c 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.4.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.4.bb
@@ -63,6 +63,11 @@ FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
FILES_${PN}-utils += "${bindir}/*"
FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
+do_configure_prepend () {
+ # executables take longer to package: these should not be executable
+ find ${WORKDIR}/xmlconf/ -type f -exec chmod -x {} \+
+}
+
do_install_ptest () {
cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
}