aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-10-20 09:54:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-25 17:51:19 +0100
commit74f30e91bca1f6af3bef0ff9e652c0591013b412 (patch)
tree7321947768632c37500264a6861cd6a81eac1219 /meta/recipes-core
parent143f9a3fa8dfd16aa107f03038383f2c578d7d49 (diff)
downloadopenembedded-core-contrib-74f30e91bca1f6af3bef0ff9e652c0591013b412.tar.gz
build-appliance-image: add /sbin to PATH
runqemu script fails with an error when executed in Build Appliance. Typical use case: $ bitbake core-image-minimal $ runqemu qemux86 Observed error: runqemu - ERROR - In order for this script to dynamically infer paths ...snip... runqemu-ifup, runqemu-ifdown or ip not found The error is caused by the fact that "ip" is located in /sbin, however /sbin is not in user's ("builder") PATH. To fix this we add /sbin to PATH. The simplest place to do this is in user's .bashrc. [YOCTO#10434] (From OE-Core rev: 7561514454c20a86e9e126af80dcf114ccd23535) Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index bb17486ed3..3ef464af3f 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -63,6 +63,9 @@ fakeroot do_populate_poky_src () {
# Also save (for reference only) the actual SRCREV used to create this image
echo "export BA_SRCREV=${SRCREV}" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+ echo "export PATH=$PATH:/sbin" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+ echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+
echo "# If working behind a proxy and using the provided oe-git-proxy script" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "# you need to set ALL_PROXY based on your proxy settings." >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "# Example ALL_PROXY values:" >> ${IMAGE_ROOTFS}/home/builder/.bashrc