aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-22 00:24:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-22 00:24:56 +0100
commit3c1807e2d85b2b6147c113645af85fc3d73c9928 (patch)
treea88f0808dfa8ba447df076f6574e9c4176c80052 /meta/recipes-core
parent46afeaba5f2cc272b9e06860a11c8eae3edc137f (diff)
downloadopenembedded-core-contrib-3c1807e2d85b2b6147c113645af85fc3d73c9928.tar.gz
uninative-tarball: Make stamp independent
The uninative tarball only contains nativesdk compoents. It should not get regenerated when MACHINE changes for example. Currently its sstate arch is also incorrect so changing SDKMACHINE results in other variants being removed from the deploy directory. This patch removes the target architecture dependencies so that deploy artefacts can overlap and it doesn't continually rebuild. This also fixes various autobuilder/release artefact issues we're having as a result of these issues. (From OE-Core rev: 6edd0b8dccc6e1e21f2ef87013e2e0a40d19b0d6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 4ead812874..0dad974238 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -18,6 +18,9 @@ INHIBIT_DEFAULT_DEPS = "1"
MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
PACKAGE_ARCH = "${SDK_ARCH}"
+PACKAGE_ARCHS = ""
+TARGET_ARCH = "none"
+TARGET_OS = "none"
TOOLCHAIN_OUTPUTNAME ?= "${SDK_ARCH}-nativesdk-libc"
@@ -27,16 +30,19 @@ EXCLUDE_FROM_WORLD = "1"
inherit meta
inherit populate_sdk
+inherit nopackages
deltask install
deltask package
deltask packagedata
+deltask populate_sysroot
do_populate_sdk[stamp-extra-info] = "${SDKMACHINE}"
SDK_DEPENDS += "patchelf-native"
SDK_PACKAGING_FUNC = ""
+REAL_MULTIMACH_TARGET_SYS = "none"
fakeroot create_sdk_files() {
cp ${COREBASE}/scripts/relocate_sdk.py ${SDK_OUTPUT}/${SDKPATH}/