aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2013-08-23 17:20:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-23 16:20:14 +0100
commit3a86c3905bf8fa724b6827f4be84704a82c115d7 (patch)
tree1756e8e905db9364a9553a4453ff2b2989a60018 /meta/recipes-core
parent747f5bee1bc60749c102552a1d7e9e419b62c7b9 (diff)
downloadopenembedded-core-contrib-3a86c3905bf8fa724b6827f4be84704a82c115d7.tar.gz
eglibc.inc: Remove quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_*
Kconfig outputs strings with quotation marks. When eglibc tries to see if the paths exists, uses wildcard make function which doesn't strip out the quotation marks - checking for path fails. So strip out the quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_* option-groups.config. (see nss/Makefile) (From OE-Core rev: eacf0f3ed15eccb52eb6b98e20b75f0aa26b6e81) Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 40dd6b5847..375b9bc116 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -75,6 +75,10 @@ do_configure_prepend() {
do_configure_append() {
oe_runmake config
+
+ # Remove quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_*. This will
+ # avoid install error.
+ sed -i 's/^OPTION_EGLIBC_NSSWITCH_FIXED_\(.*\)="\(.*\)"$/OPTION_EGLIBC_NSSWITCH_FIXED_\1=\2/' option-groups.config
}
GLIBC_ADDONS ?= "ports,nptl,libidn"