aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorJunling Zheng <zhengjunling@huawei.com>2015-06-07 07:52:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:42 +0100
commit6ec65eedb63a82159dde8f2b2825ba7d5e6ae81d (patch)
tree1d91712f5b7259f591604c96ac6460bb2144f7fb /meta/recipes-core
parent66ec540dad77052bc2c1da3a87f875547600efad (diff)
downloadopenembedded-core-contrib-6ec65eedb63a82159dde8f2b2825ba7d5e6ae81d.tar.gz
busybox: fix the wrong help text for chown
Only when DESKTOP is enabled, chown has -L, -H and -P options. Backport a commit from upstream to fix it: http://git.busybox.net/busybox/commit/?id=d291c2fdd5cb8616605c67ecbfb04274fa094242. Signed-off-by: Junling Zheng <zhengjunling@huawei.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/busybox/busybox/0001-chown-fix-help-text.patch34
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.2.bb1
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb1
3 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/0001-chown-fix-help-text.patch b/meta/recipes-core/busybox/busybox/0001-chown-fix-help-text.patch
new file mode 100644
index 0000000000..4299799664
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/0001-chown-fix-help-text.patch
@@ -0,0 +1,34 @@
+From d291c2fdd5cb8616605c67ecbfb04274fa094242 Mon Sep 17 00:00:00 2001
+From: Junling Zheng <zhengjunling@huawei.com>
+Date: Sun, 7 Jun 2015 02:32:23 +0200
+Subject: [PATCH] chown: fix help text
+
+Derived from:
+http://git.busybox.net/busybox/commit/?id=d291c2fdd5cb8616605c67ecbfb04274fa094242.
+
+Only when DESKTOP is enabled, chown has -L, -H and -P options.
+
+Upstream-Status: Backport
+
+Signed-off-by: Junling Zheng <zhengjunling@huawei.com>
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ coreutils/chown.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/coreutils/chown.c b/coreutils/chown.c
+index cb07bbc..679c0d8 100644
+--- a/coreutils/chown.c
++++ b/coreutils/chown.c
+@@ -11,7 +11,7 @@
+ /* http://www.opengroup.org/onlinepubs/007904975/utilities/chown.html */
+
+ //usage:#define chown_trivial_usage
+-//usage: "[-RhLHP"IF_DESKTOP("cvf")"]... OWNER[<.|:>[GROUP]] FILE..."
++//usage: "[-Rh"IF_DESKTOP("LHPcvf")"]... OWNER[<.|:>[GROUP]] FILE..."
+ //usage:#define chown_full_usage "\n\n"
+ //usage: "Change the owner and/or group of each FILE to OWNER and/or GROUP\n"
+ //usage: "\n -R Recurse"
+--
+1.8.3.4
+
diff --git a/meta/recipes-core/busybox/busybox_1.23.2.bb b/meta/recipes-core/busybox/busybox_1.23.2.bb
index f7bf8e2544..85e462ec58 100644
--- a/meta/recipes-core/busybox/busybox_1.23.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.23.2.bb
@@ -31,6 +31,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://recognize_connmand.patch \
file://busybox-cross-menuconfig.patch \
file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
+ file://0001-chown-fix-help-text.patch \
"
SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
index 675e56afd0..c5596d8ed0 100644
--- a/meta/recipes-core/busybox/busybox_git.bb
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -37,6 +37,7 @@ SRC_URI = "git://busybox.net/busybox.git \
file://recognize_connmand.patch \
file://busybox-cross-menuconfig.patch \
file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
+ file://0001-chown-fix-help-text.patch \
"
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"