aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-28 02:16:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:34:38 +0100
commit66e4a0d10a382618fe925b33a9d6df3ee49297e2 (patch)
treebbc03570619902a1a86b7993c863718fc4674bcb /meta/recipes-core
parent05360e6e5e82395ef3a5035b62b805d22592d571 (diff)
downloadopenembedded-core-contrib-66e4a0d10a382618fe925b33a9d6df3ee49297e2.tar.gz
glibc: ignore for musl/uclibc but only for target recipes
we still need nativesdk or native recipes for libc to come from glibc, but only be ignored for target recipes types Change-Id: Ibaf8114f2aef63f1eadf493b264e78cd928535a0 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glibc/glibc-collateral.inc3
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb9
2 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-core/glibc/glibc-collateral.inc b/meta/recipes-core/glibc/glibc-collateral.inc
index f82db06cb9..60655eba3c 100644
--- a/meta/recipes-core/glibc/glibc-collateral.inc
+++ b/meta/recipes-core/glibc/glibc-collateral.inc
@@ -17,3 +17,6 @@ do_compile[noexec] = "1"
do_install[depends] += "virtual/${MLPREFIX}libc:do_populate_sysroot"
+COMPATIBLE_HOST_libc-musl_class-target = "null"
+COMPATIBLE_HOST_libc-uclibc_class-target = "null"
+
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 81b5a2bdbd..8197c29d2e 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -70,14 +70,11 @@ TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
#
-# We will skip parsing glibc when system C library selection is not glibc
+# We will skip parsing glibc when target system C library selection is not glibc
# this helps in easing out parsing for non-glibc system libraries
#
-python __anonymous () {
- if d.getVar('TCLIBC', True) != "glibc":
- raise bb.parse.SkipPackage("incompatible with %s C library" %
- d.getVar('TCLIBC', True))
-}
+COMPATIBLE_HOST_libc-musl_class-target = "null"
+COMPATIBLE_HOST_libc-uclibc_class-target = "null"
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile \