aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-12-01 17:04:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 16:53:56 +0000
commite1312eef88cb0f3f1557d431f0b31520b2a9968e (patch)
tree779bc35911be60380b74b2e3e9a399b448786519 /meta/recipes-core/zlib
parent508ff624fea705eb93cf2cc1e0c9c42cb817acf8 (diff)
downloadopenembedded-core-contrib-e1312eef88cb0f3f1557d431f0b31520b2a9968e.tar.gz
zlib 1.2.5: install pkgconfig file, needed for e.g. modern webkit
Upstream has grown cmake support which would allow us to dump the OE autotools hack, but the cmakefile doesn't install the .pc file either and breaks with zlib-native Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib')
-rw-r--r--meta/recipes-core/zlib/zlib_1.2.5.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta/recipes-core/zlib/zlib_1.2.5.bb b/meta/recipes-core/zlib/zlib_1.2.5.bb
index bca400ce4b..b5756d9424 100644
--- a/meta/recipes-core/zlib/zlib_1.2.5.bb
+++ b/meta/recipes-core/zlib/zlib_1.2.5.bb
@@ -7,12 +7,12 @@ LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://zlib.h;beginline=4;endline=23;md5=084e9c30e4e6272c3b057b13c6467f3d"
DEPENDS = "libtool-cross"
-PR = "r1"
+PR = "r3"
SRC_URI = "http://www.zlib.net/${BPN}-${PV}.tar.bz2 \
file://configure.ac \
file://Makefile.am \
- file://fix.inverted.LFS.logic.patch"
+ file://fix.inverted.LFS.logic.patch"
SRC_URI[md5sum] = "be1e89810e66150f5b0327984d8625a0"
SRC_URI[sha256sum] = "239aead2f22f16bfcfa6a6a5150dcbd6d6f2e4d1eaa8727b5769ea014120b307"
@@ -24,4 +24,18 @@ do_configure_prepend () {
cp ${WORKDIR}/Makefile.am ${S}/
}
+do_install_append () {
+ sed \
+ -e 's:@prefix@:${prefix}:' \
+ -e 's:@exec_prefix@:${exec_prefix}:' \
+ -e 's:@libdir@:${libdir}:' \
+ -e 's:@sharedlibdir@:${libdir}:' \
+ -e 's:@includedir@:${includedir}:' \
+ -e 's:@VERSION@:${PV}:' \
+ zlib.pc.in > zlib.pc
+
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 zlib.pc ${D}${libdir}/pkgconfig/
+}
+
BBCLASSEXTEND = "native nativesdk"