aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-11-27 09:02:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-27 11:58:05 +0000
commit2988cef2f0ad857b5bbf6a0189ffb0fb88795f8c (patch)
treeeaa870cdb25713b38a52315c462c611838cbd3b1 /meta/recipes-core/zlib
parente840f526e7223c9d393aab818c7a5a446b89c503 (diff)
downloadopenembedded-core-contrib-2988cef2f0ad857b5bbf6a0189ffb0fb88795f8c.tar.gz
zlib: Add ptest
Install zlib tests and run them as ptest Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib')
-rw-r--r--meta/recipes-core/zlib/zlib-1.2.8/Makefile-runtests.patch38
-rw-r--r--meta/recipes-core/zlib/zlib-1.2.8/run-ptest2
-rw-r--r--meta/recipes-core/zlib/zlib_1.2.8.bb18
3 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/zlib/zlib-1.2.8/Makefile-runtests.patch b/meta/recipes-core/zlib/zlib-1.2.8/Makefile-runtests.patch
new file mode 100644
index 0000000000..61eea8238a
--- /dev/null
+++ b/meta/recipes-core/zlib/zlib-1.2.8/Makefile-runtests.patch
@@ -0,0 +1,38 @@
+Add 'ptest' target to Makefile, to run tests without checking dependencies.
+
+Signed-off-by: Anders Roxell <anders.roxell@enea.com>
+Upstream-Status: Pending
+---
+diff -uNr a/Makefile.in b/Makefile.in
+--- a/Makefile.in 2013-06-10 13:48:14.321959162 +0200
++++ b/Makefile.in 2013-06-10 13:49:36.686476448 +0200
+@@ -83,6 +83,9 @@
+ test: all teststatic testshared
+
+ teststatic: static
++ @make runteststatic
++
++runteststatic:
+ @TMPST=tmpst_$$; \
+ if echo hello world | ./minigzip | ./minigzip -d && ./example $$TMPST ; then \
+ echo ' *** zlib test OK ***'; \
+@@ -92,6 +95,9 @@
+ rm -f $$TMPST
+
+ testshared: shared
++ @make runtestshared
++
++runtestshared:
+ @LD_LIBRARY_PATH=`pwd`:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
+ LD_LIBRARYN32_PATH=`pwd`:$(LD_LIBRARYN32_PATH) ; export LD_LIBRARYN32_PATH; \
+ DYLD_LIBRARY_PATH=`pwd`:$(DYLD_LIBRARY_PATH) ; export DYLD_LIBRARY_PATH; \
+@@ -105,6 +111,9 @@
+ rm -f $$TMPSH
+
+ test64: all64
++ @make runtestall64
++
++runtestall64:
+ @TMP64=tmp64_$$; \
+ if echo hello world | ./minigzip64 | ./minigzip64 -d && ./example64 $$TMP64; then \
+ echo ' *** zlib 64-bit test OK ***'; \
diff --git a/meta/recipes-core/zlib/zlib-1.2.8/run-ptest b/meta/recipes-core/zlib/zlib-1.2.8/run-ptest
new file mode 100644
index 0000000000..884d9dc699
--- /dev/null
+++ b/meta/recipes-core/zlib/zlib-1.2.8/run-ptest
@@ -0,0 +1,2 @@
+#!/bin/sh
+make -k runteststatic runtestshared | sed -r -e 's/^(\s+\*+ (.+?) test OK \*+)/\1\nPASS: \2/' -e 's/^(\s+\*+ (.+?) test FAILED \*+)/\1\nFAIL: \2/'
diff --git a/meta/recipes-core/zlib/zlib_1.2.8.bb b/meta/recipes-core/zlib/zlib_1.2.8.bb
index 5cdf68584b..bdfa045b7b 100644
--- a/meta/recipes-core/zlib/zlib_1.2.8.bb
+++ b/meta/recipes-core/zlib/zlib_1.2.8.bb
@@ -9,11 +9,17 @@ LIC_FILES_CHKSUM = "file://zlib.h;beginline=4;endline=23;md5=fde612df1e5933c428b
SRC_URI = "http://www.zlib.net/${BPN}-${PV}.tar.xz \
file://remove.ldconfig.call.patch \
+ file://Makefile-runtests.patch \
+ file://run-ptest \
"
SRC_URI[md5sum] = "28f1205d8dd2001f26fec1e8c2cebe37"
SRC_URI[sha256sum] = "831df043236df8e9a7667b9e3bb37e1fcb1220a0f163b6de2626774b9590d057"
+RDEPENDS_${PN}-ptest += "make"
+
+inherit ptest
+
do_configure (){
./configure --prefix=${prefix} --shared --libdir=${libdir}
}
@@ -22,10 +28,22 @@ do_compile (){
oe_runmake
}
+do_compile_ptest() {
+ oe_runmake static shared
+}
+
do_install() {
oe_runmake DESTDIR=${D} install
}
+do_install_ptest() {
+ install ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/example ${D}${PTEST_PATH}
+ install ${B}/minigzip ${D}${PTEST_PATH}
+ install ${B}/examplesh ${D}${PTEST_PATH}
+ install ${B}/minigzipsh ${D}${PTEST_PATH}
+}
+
# We move zlib shared libraries for target builds to avoid
# qa warnings.
#