summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/zlib
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-26 12:02:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-26 14:03:48 +0000
commitea86bdb8935668d41e142676815af38911ee0faa (patch)
tree5414b4422f6b97722809dbfe9e947c73e452cb48 /meta/recipes-core/zlib/zlib
parent2b6c855737afbf2b0f2baa1b14029f8ddc37e9ed (diff)
downloadopenembedded-core-contrib-ea86bdb8935668d41e142676815af38911ee0faa.tar.gz
zlib: clean up ptest
Instead of patching and sedding the makefile, just install test/example and execute it in run-ptest. example is the bulk of the test suite, as minimal as it is. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/zlib')
-rw-r--r--meta/recipes-core/zlib/zlib/Makefile-runtests.patch38
-rw-r--r--meta/recipes-core/zlib/zlib/run-ptest7
2 files changed, 6 insertions, 39 deletions
diff --git a/meta/recipes-core/zlib/zlib/Makefile-runtests.patch b/meta/recipes-core/zlib/zlib/Makefile-runtests.patch
deleted file mode 100644
index 61eea8238a..0000000000
--- a/meta/recipes-core/zlib/zlib/Makefile-runtests.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Add 'ptest' target to Makefile, to run tests without checking dependencies.
-
-Signed-off-by: Anders Roxell <anders.roxell@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/Makefile.in b/Makefile.in
---- a/Makefile.in 2013-06-10 13:48:14.321959162 +0200
-+++ b/Makefile.in 2013-06-10 13:49:36.686476448 +0200
-@@ -83,6 +83,9 @@
- test: all teststatic testshared
-
- teststatic: static
-+ @make runteststatic
-+
-+runteststatic:
- @TMPST=tmpst_$$; \
- if echo hello world | ./minigzip | ./minigzip -d && ./example $$TMPST ; then \
- echo ' *** zlib test OK ***'; \
-@@ -92,6 +95,9 @@
- rm -f $$TMPST
-
- testshared: shared
-+ @make runtestshared
-+
-+runtestshared:
- @LD_LIBRARY_PATH=`pwd`:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
- LD_LIBRARYN32_PATH=`pwd`:$(LD_LIBRARYN32_PATH) ; export LD_LIBRARYN32_PATH; \
- DYLD_LIBRARY_PATH=`pwd`:$(DYLD_LIBRARY_PATH) ; export DYLD_LIBRARY_PATH; \
-@@ -105,6 +111,9 @@
- rm -f $$TMPSH
-
- test64: all64
-+ @make runtestall64
-+
-+runtestall64:
- @TMP64=tmp64_$$; \
- if echo hello world | ./minigzip64 | ./minigzip64 -d && ./example64 $$TMP64; then \
- echo ' *** zlib 64-bit test OK ***'; \
diff --git a/meta/recipes-core/zlib/zlib/run-ptest b/meta/recipes-core/zlib/zlib/run-ptest
index 884d9dc699..065863ef75 100644
--- a/meta/recipes-core/zlib/zlib/run-ptest
+++ b/meta/recipes-core/zlib/zlib/run-ptest
@@ -1,2 +1,7 @@
#!/bin/sh
-make -k runteststatic runtestshared | sed -r -e 's/^(\s+\*+ (.+?) test OK \*+)/\1\nPASS: \2/' -e 's/^(\s+\*+ (.+?) test FAILED \*+)/\1\nFAIL: \2/'
+
+if ./examplesh ; then
+ echo "PASS: zlib"
+else
+ echo "FAIL: zlib"
+fi