aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch
diff options
context:
space:
mode:
authorPeter Marko <peter.marko@siemens.com>2017-02-27 20:26:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-08 11:13:48 +0000
commit8b15b7bd10db83b3390827231b54aeb3452bcb6f (patch)
treecdfd7e1d239ac8ddf1bcbb5f2941bea53a742f98 /meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch
parent2c126e704ebb58afc0d79fe220dc370e09d6bfd5 (diff)
downloadopenembedded-core-contrib-8b15b7bd10db83b3390827231b54aeb3452bcb6f.tar.gz
zlib: Upgrade 1.2.8 -> 1.2.11
Licence updated by removing its first line which was containing copyright notice including year, which could change quite often. Additional empty line was deleted, too. Signed-off-by: Peter Marko <peter.marko@siemens.com> Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch')
-rw-r--r--meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch b/meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch
new file mode 100644
index 0000000000..61eea8238a
--- /dev/null
+++ b/meta/recipes-core/zlib/zlib-1.2.11/Makefile-runtests.patch
@@ -0,0 +1,38 @@
+Add 'ptest' target to Makefile, to run tests without checking dependencies.
+
+Signed-off-by: Anders Roxell <anders.roxell@enea.com>
+Upstream-Status: Pending
+---
+diff -uNr a/Makefile.in b/Makefile.in
+--- a/Makefile.in 2013-06-10 13:48:14.321959162 +0200
++++ b/Makefile.in 2013-06-10 13:49:36.686476448 +0200
+@@ -83,6 +83,9 @@
+ test: all teststatic testshared
+
+ teststatic: static
++ @make runteststatic
++
++runteststatic:
+ @TMPST=tmpst_$$; \
+ if echo hello world | ./minigzip | ./minigzip -d && ./example $$TMPST ; then \
+ echo ' *** zlib test OK ***'; \
+@@ -92,6 +95,9 @@
+ rm -f $$TMPST
+
+ testshared: shared
++ @make runtestshared
++
++runtestshared:
+ @LD_LIBRARY_PATH=`pwd`:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
+ LD_LIBRARYN32_PATH=`pwd`:$(LD_LIBRARYN32_PATH) ; export LD_LIBRARYN32_PATH; \
+ DYLD_LIBRARY_PATH=`pwd`:$(DYLD_LIBRARY_PATH) ; export DYLD_LIBRARY_PATH; \
+@@ -105,6 +111,9 @@
+ rm -f $$TMPSH
+
+ test64: all64
++ @make runtestall64
++
++runtestall64:
+ @TMP64=tmp64_$$; \
+ if echo hello world | ./minigzip64 | ./minigzip64 -d && ./example64 $$TMP64; then \
+ echo ' *** zlib 64-bit test OK ***'; \