aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/volatile-binds
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-03-30 18:06:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-31 12:10:21 +0100
commit4a44a7658cebafab336f061f270b6ff44150a6d6 (patch)
tree439b615a61118d09d2d837bcb0074552032a6c2d /meta/recipes-core/volatile-binds
parentee7c19546b686e852d01df25143504d9798d10d6 (diff)
downloadopenembedded-core-contrib-4a44a7658cebafab336f061f270b6ff44150a6d6.tar.gz
volatile-binds: correct some errors reported by systemd
systemd-tmpfiles-setup will fail at boot, so we suppress the default versions of etc.conf and home.conf. We also make sure that /var/{cache,spool} and /srv are writeable if they exist. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/volatile-binds')
-rw-r--r--meta/recipes-core/volatile-binds/volatile-binds.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-core/volatile-binds/volatile-binds.bb b/meta/recipes-core/volatile-binds/volatile-binds.bb
index f07458acc0..a6e3254930 100644
--- a/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -17,6 +17,9 @@ REQUIRED_DISTRO_FEATURES = "systemd"
VOLATILE_BINDS ?= "\
/var/volatile/lib /var/lib\n\
+ /var/volatile/cache /var/cache\n\
+ /var/volatile/spool /var/spool\n\
+ /var/volatile/srv /srv\n\
"
VOLATILE_BINDS[type] = "list"
VOLATILE_BINDS[separator] = "\n"
@@ -67,5 +70,11 @@ do_install () {
for service in ${SYSTEMD_SERVICE_volatile-binds}; do
install -m 0644 $service ${D}${systemd_unitdir}/system/
done
+
+ # Suppress attempts to process some tmpfiles that are not temporary.
+ #
+ install -d ${D}${sysconfdir}/tmpfiles.d ${D}/var/cache
+ ln -s /dev/null ${D}${sysconfdir}/tmpfiles.d/etc.conf
+ ln -s /dev/null ${D}${sysconfdir}/tmpfiles.d/home.conf
}
do_install[dirs] = "${WORKDIR}"