summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/volatile-binds
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2021-08-26 05:42:06 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-07 21:52:04 +0100
commit5ace3ada5c54500c71becc8e0c6eddeb8bc053e3 (patch)
treeca5003f9ea787078a02d3ce9d8fa78cb6ebe0b44 /meta/recipes-core/volatile-binds
parentaec6fcb98c7dabf16779efb333be09d73d9f4ee0 (diff)
downloadopenembedded-core-contrib-5ace3ada5c54500c71becc8e0c6eddeb8bc053e3.tar.gz
systemd: '${systemd_unitdir}/system' => '${systemd_system_unitdir}'
Repo-wide replacement to use newer variable to represent systemd system unitdir directory. Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/volatile-binds')
-rw-r--r--meta/recipes-core/volatile-binds/volatile-binds.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/volatile-binds/volatile-binds.bb b/meta/recipes-core/volatile-binds/volatile-binds.bb
index b693c24c4c..d5c5538cd7 100644
--- a/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -35,7 +35,7 @@ def volatile_systemd_services(d):
SYSTEMD_SERVICE:${PN} = "${@volatile_systemd_services(d)}"
-FILES:${PN} += "${systemd_unitdir}/system/*.service ${servicedir}"
+FILES:${PN} += "${systemd_system_unitdir}/*.service ${servicedir}"
do_compile () {
while read spec mountpoint; do
@@ -67,9 +67,9 @@ do_install () {
install -d ${D}${servicedir}
install -m 0755 mount-copybind ${D}${base_sbindir}/
- install -d ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_system_unitdir}
for service in ${SYSTEMD_SERVICE:${PN}}; do
- install -m 0644 $service ${D}${systemd_unitdir}/system/
+ install -m 0644 $service ${D}${systemd_system_unitdir}/
done
# Suppress attempts to process some tmpfiles that are not temporary.