aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/update-rc.d/update-rc.d_0.8.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-25 11:11:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:28 +0100
commit531e363db08711b5390af16f5491ca8a71a0610c (patch)
tree4746f804c3e8bd502048097f8ce08ee5eb070be4 /meta/recipes-core/update-rc.d/update-rc.d_0.8.bb
parent29fc6fff32b05900526bf2426ba69a9a2d1f24f2 (diff)
downloadopenembedded-core-contrib-531e363db08711b5390af16f5491ca8a71a0610c.tar.gz
update-rc.d: move to git.yoctoproject.org
The update-rc.d repository is now on git.yoctoproject.org, and has merged all of the patches we were carrying. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/update-rc.d/update-rc.d_0.8.bb')
-rw-r--r--meta/recipes-core/update-rc.d/update-rc.d_0.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/update-rc.d/update-rc.d_0.8.bb b/meta/recipes-core/update-rc.d/update-rc.d_0.8.bb
new file mode 100644
index 0000000000..baa21aeae1
--- /dev/null
+++ b/meta/recipes-core/update-rc.d/update-rc.d_0.8.bb
@@ -0,0 +1,26 @@
+SUMMARY = "manage symlinks in /etc/rcN.d"
+HOMEPAGE = "http://github.com/philb/update-rc.d/"
+DESCRIPTION = "update-rc.d is a utility that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
+SECTION = "base"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
+
+SRC_URI = "git://git.yoctoproject.org/update-rc.d"
+SRCREV = "22e0692898c3e7ceedc8eb5ff4ec8e0b9c340b2d"
+
+UPSTREAM_CHECK_COMMITS = "1"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
+}
+
+BBCLASSEXTEND = "native nativesdk"