aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2016-01-05 17:11:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-05 17:55:05 +0000
commit95fced137a46dc98863fe5af7be5cbce708602f2 (patch)
tree90e6651e98feecb56d226193d8e58457bd7c2d38 /meta/recipes-core/udev
parent6bb6fd592ca9caac75504b8c339e20ab54c0cae9 (diff)
downloadopenembedded-core-contrib-95fced137a46dc98863fe5af7be5cbce708602f2.tar.gz
udev-extraconf: introduce multiple blacklist files for more complex setups
In cases where a target image wants prevent the recovery partition is mounted automatically, but the recovery partition identifier moves with the device (internal flash, sd card, usb stick, ...), device/machine dependend extra blacklists might be desired. The grep utility prints the file name for each match when there is more than one file to search. Add -h to suppress the prefixing of file names on output. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/udev')
-rw-r--r--meta/recipes-core/udev/udev-extraconf/mount.sh2
-rw-r--r--meta/recipes-core/udev/udev-extraconf_1.1.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/udev/udev-extraconf/mount.sh b/meta/recipes-core/udev/udev-extraconf/mount.sh
index 3eea910854..d760328a09 100644
--- a/meta/recipes-core/udev/udev-extraconf/mount.sh
+++ b/meta/recipes-core/udev/udev-extraconf/mount.sh
@@ -8,7 +8,7 @@
MOUNT="/bin/mount"
PMOUNT="/usr/bin/pmount"
UMOUNT="/bin/umount"
-for line in `grep -v ^# /etc/udev/mount.blacklist`
+for line in `grep -h -v ^# /etc/udev/mount.blacklist /etc/udev/mount.blacklist.d/*`
do
if [ ` expr match "$DEVNAME" "$line" ` -gt 0 ];
then
diff --git a/meta/recipes-core/udev/udev-extraconf_1.1.bb b/meta/recipes-core/udev/udev-extraconf_1.1.bb
index 6fbd92548a..ecd4a8aab5 100644
--- a/meta/recipes-core/udev/udev-extraconf_1.1.bb
+++ b/meta/recipes-core/udev/udev-extraconf_1.1.bb
@@ -23,6 +23,7 @@ do_install() {
install -m 0644 ${WORKDIR}/autonet.rules ${D}${sysconfdir}/udev/rules.d/autonet.rules
install -m 0644 ${WORKDIR}/localextra.rules ${D}${sysconfdir}/udev/rules.d/localextra.rules
+ install -d ${D}${sysconfdir}/udev/mount.blacklist.d
install -m 0644 ${WORKDIR}/mount.blacklist ${D}${sysconfdir}/udev/
install -d ${D}${sysconfdir}/udev/scripts/