aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/sysvinit
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-09-11 12:56:53 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 14:44:54 +0100
commit019a95a5e01bd3fefaaab0a27029ed8b26ee3c79 (patch)
tree307197889ae17c5f10b9fffc6feb438c9309da05 /meta/recipes-core/sysvinit
parent7121fe8d836fc178e9ab8f0e6f8eb34a99325c81 (diff)
downloadopenembedded-core-contrib-019a95a5e01bd3fefaaab0a27029ed8b26ee3c79.tar.gz
sysvinit-inittab_2.88dsf.bb: only run serial checks at boot if we have items to check
Right now, we delay running the serial console checks to we boot up. This causes issues for read only file systems. So, if have not configured any serial ports to check via SERIAL_CONSOLES_CHECK we can skip the check at boot. This fixes any issues with read only file systems and ipk packaging. Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/sysvinit')
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index 1089edbcb4..5b79caffc2 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Inittab for sysvinit"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r7"
+PR = "r8"
SRC_URI = "file://inittab"
@@ -54,7 +54,7 @@ EOF
pkg_postinst_${PN} () {
# run this on the target
-if [ "x$D" == "x" ]; then
+if [ "x$D" = "x" ]; then
tmp="${SERIAL_CONSOLES_CHECK}"
for i in $tmp
do
@@ -65,7 +65,11 @@ if [ "x$D" == "x" ]; then
done
kill -HUP 1
else
- exit 1
+ if [ "${SERIAL_CONSOLES_CHECK}" = "" ]; then
+ exit 0
+ else
+ exit 1
+ fi
fi
}