aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-09-26 16:41:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-26 11:07:36 +0100
commitabf2e9526a11bcb51b71b90a7b76bd33af656494 (patch)
treed7b640948d6cec6ec5e74c50db81a8ae408a90cb /meta/recipes-core/systemd
parent8c9ee404fe2a5e703f14c70092137c8d0ac0a6c2 (diff)
downloadopenembedded-core-contrib-abf2e9526a11bcb51b71b90a7b76bd33af656494.tar.gz
systemd-serialtty: allow empty package
If SERIAL_CONSOLES is set to empty for some reason, we would have rootfs failure like below. - nothing provides systemd-serialgetty needed by systemd-1:234-r0.core2_64 This is because systemd-serialgetty package is not generated when SERIAL_CONSOLES is empty. Set ALLOW_EMPTY to "1" for this recipe to allow for generation of empty systemd-serialgetty package to avoid the above error. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 74b5986730..d9347163b5 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -48,3 +48,5 @@ python () {
if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
}
+
+ALLOW_EMPTY_${PN} = "1"