summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-01-09 23:27:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-11 10:53:39 +0000
commitfde5147206ae82d11819fcc23fbe4fc2f94ea52b (patch)
tree8ed079dbe0af8052d1db522d501f7296547943a9 /meta/recipes-core/systemd
parent743d09665a4ef743b1fa9ac382a713556dfce1a1 (diff)
downloadopenembedded-core-contrib-fde5147206ae82d11819fcc23fbe4fc2f94ea52b.tar.gz
systemd-boot: restore reproducibility
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd.inc3
-rw-r--r--meta/recipes-core/systemd/systemd/0001-src-fundamental-list-fundamental_source_paths-using-.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd.inc b/meta/recipes-core/systemd/systemd.inc
index e416f8d64b..6739018559 100644
--- a/meta/recipes-core/systemd/systemd.inc
+++ b/meta/recipes-core/systemd/systemd.inc
@@ -17,6 +17,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
SRCREV = "402280118fe082122437638f53a0019c4aea81aa"
SRCBRANCH = "v250-stable"
SRC_URI = "git://github.com/systemd/systemd-stable.git;protocol=https;branch=${SRCBRANCH} \
-"
+ file://0001-src-fundamental-list-fundamental_source_paths-using-.patch \
+ "
S = "${WORKDIR}/git"
diff --git a/meta/recipes-core/systemd/systemd/0001-src-fundamental-list-fundamental_source_paths-using-.patch b/meta/recipes-core/systemd/systemd/0001-src-fundamental-list-fundamental_source_paths-using-.patch
new file mode 100644
index 0000000000..1d0887490c
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-src-fundamental-list-fundamental_source_paths-using-.patch
@@ -0,0 +1,28 @@
+From 8e882df78ede98c15a3f2567fabebfde1d774b02 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Fri, 7 Jan 2022 21:20:15 +0100
+Subject: [PATCH] src/fundamental: list fundamental_source_paths using relative
+ paths
+
+Otherwise, the compiler takes the full path to the source file
+and writes it into the binary output, breaking reproducibility.
+
+Upstream-Status: Submitted [https://github.com/systemd/systemd/pull/22047]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ src/fundamental/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/fundamental/meson.build b/src/fundamental/meson.build
+index 287f0fe36a..954bdf150b 100644
+--- a/src/fundamental/meson.build
++++ b/src/fundamental/meson.build
+@@ -20,7 +20,7 @@ sources = '''
+ # for sd-boot
+ fundamental_source_paths = []
+ foreach source : sources
+- fundamental_source_paths += meson.current_source_dir() / source
++ fundamental_source_paths += '../../fundamental/' + source
+ endforeach
+
+ # for libbasic