aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-09 08:56:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:30 +0000
commitff8006f06f989ed6a36462cd27759d528f2c574c (patch)
tree4feae6287c6ff7cc86171014e0f4b0273feb4968 /meta/recipes-core/systemd
parentf2856a121258ef6b3aa5450fadecf7b4c4ab4d53 (diff)
downloadopenembedded-core-contrib-ff8006f06f989ed6a36462cd27759d528f2c574c.tar.gz
systemd: Skip parsing on musl based targets
systemd on musl doesn't yet work even though we have patches to make it compile it fails to run, therefore lets skip building it for now (From OE-Core rev: a1986acf66381dee18f5c8deae7cf52490d0f58a) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd_228.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_228.bb b/meta/recipes-core/systemd/systemd_228.bb
index aa2e846b69..0e1bd8b7f1 100644
--- a/meta/recipes-core/systemd/systemd_228.bb
+++ b/meta/recipes-core/systemd/systemd_228.bb
@@ -443,4 +443,8 @@ pkg_prerm_udev-hwdb () {
python () {
if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+
+ import re
+ if re.match('.*musl*', d.getVar('TARGET_OS', True)) != None:
+ raise bb.parse.SkipPackage("Not _yet_ supported on musl based targets")
}