aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_234.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-12-19 16:23:40 +0800
committerRobert Yang <liezhi.yang@windriver.com>2017-12-20 09:51:34 +0800
commiteffbd3d25e0509d870f5a658dd24c93c27924cba (patch)
tree7165bb036f08e333e4f7a52d9fdcd973d6ae8dda /meta/recipes-core/systemd/systemd_234.bb
parent8321b1389864798845fb943888e43a89c60a8d4c (diff)
downloadopenembedded-core-contrib-rbt/systemd.tar.gz
systemd: inherit distro_features_checkrbt/systemd
Use distro_features_check so that we can have a uniform controller. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_234.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 778b8681a9..58426ca267 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -8,7 +8,11 @@ DEPENDS = "kmod intltool-native gperf-native acl readline libcap libcgroup util-
SECTION = "base/shell"
-inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages
+inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages distro_features_check
+
+# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
+# that we don't build both udev and systemd in world builds.
+REQUIRED_DISTRO_FEATURES = "systemd"
SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \
file://touchscreen.rules \
@@ -633,10 +637,3 @@ pkg_postinst_udev-hwdb () {
pkg_prerm_udev-hwdb () {
rm -f $D${sysconfdir}/udev/hwdb.bin
}
-
-# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
-# that we don't build both udev and systemd in world builds.
-python () {
- if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
- raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
-}