aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_225.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-09-06 15:25:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-11 23:38:02 +0100
commit9d298d1563b3fd5ad569f806cc296e13279e7cf6 (patch)
tree66e77ca178fe2645bb7eb8092425b0913f10275e /meta/recipes-core/systemd/systemd_225.bb
parentec2770b0d1d562ff6d5736e056f937fa24c67b10 (diff)
downloadopenembedded-core-contrib-9d298d1563b3fd5ad569f806cc296e13279e7cf6.tar.gz
systemd: Implement OE-Specific systemd-sysv-install
Support for chkconfig (--enable-chkconfig) was removed in favour of calling an abstraction /lib/systemd/systemd-sysv-install. This needs to be implemented for OE. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_225.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_225.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_225.bb b/meta/recipes-core/systemd/systemd_225.bb
index 2dc8884839..6ac99cd63c 100644
--- a/meta/recipes-core/systemd/systemd_225.bb
+++ b/meta/recipes-core/systemd/systemd_225.bb
@@ -38,6 +38,7 @@ SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \
file://0009-sysv-generator-add-support-for-executing-scripts-und.patch \
file://0010-Make-root-s-home-directory-configurable.patch \
file://0011-systemd-user-avoid-using-system-auth.patch \
+ file://0012-implment-systemd-sysv-install-for-OE.patch \
file://0014-Revert-rules-remove-firmware-loading-rules.patch \
file://0015-Revert-udev-remove-userspace-firmware-loading-suppor.patch \
file://touchscreen.rules \
@@ -188,6 +189,7 @@ do_install() {
if [ -s ${D}${libdir}/tmpfiles.d/systemd.conf ]; then
${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
fi
+ install -Dm 0755 ${S}/src/systemctl/systemd-sysv-install.SKELETON ${D}${systemd_unitdir}/systemd-sysv-install
}
do_install_ptest () {
@@ -309,7 +311,7 @@ FILES_${PN}-dbg += "${rootlibdir}/.debug ${systemd_unitdir}/.debug ${systemd_uni
FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd"
RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV})"
-RDEPENDS_${PN} += "volatile-binds"
+RDEPENDS_${PN} += "volatile-binds update-rc.d"
RRECOMMENDS_${PN} += "systemd-serialgetty systemd-vconsole-setup \
systemd-compat-units udev-hwdb \